Software and data preparation requirements for AstroGrid DSA/Catalog Hands-On Session

System requirements for installing AstroGrid DSA:

  • Java 1.5
  • Apache Tomcat (suggested version: 5.0.28 (recommended) or 5.5.20)
  • The latest AstroGrid DSA/catalog component: Download it now
Linux/unix is also recommended.

Notes for those wishing to wrap their own catalogue data

The following RDBMS systems are known to work with the DSA/catalog component:
  • MySQL (tested against v. 4.1)
  • PostgreSQL (tested against v. 7.2, v. 8.1)
  • Microsoft SQL Server (tested against v. 8.0)
  • Sybase (tested against v. 15.0)
  • HSQLDB (tested against v. 1.8)
Other (later) versions of these RDBMS systems are also likely to work; earlier versions may not. Oracle is currently not supported, but we hope it will be soon.

Sample data will be supplied for use in the DSA/catalog Hands-On Session. However, you are encouraged to try installing a DSA/catalog component against some of your own data. To do this, you can either:

  • Bring your own data on your laptop, pre-loaded into a suitable RDBMS installation on the laptop
  • Access your "real" data on a remote RDBMS installation, which will require:
    • Remote JDBC access (can be read-only) enabled for one or more databases in your remote RDBMS
    • Knowledge of the relevant JDBC username and password for that JDBC access
    • JDBC access enabled on one of these "standard" ports: 3306 (MySQL ), 5432 (PostgreSQL ), 1433 (SQLServer). (any other ports may be blocked by the firewall).

-- KonaAndrews - 18 Jun 2007

Topic revision: r4 - 21 Jun 2007 - 11:30:58 - KonaAndrews
 
This site is powered by the TWiki collaboration platformCopyright © by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback